Unable to open CMake on Windows 10

Hello,

I’m trying to use CMake GUI (cmake-3.16.5-win64-x64) for building a certain project. I’m using Windows 10 Pro version 1903.
When I’m trying to open CMake (executing cmake-gui), the program appears in the windows toolbar, but doesn’t show any window, thus I’m unable to do anything with CMake. CMake seems to be stable, so that it shows up in task management and when I close it there, it closes as it should. I have uninstalled CMake from my computer and deleted the installer tool and then downloaded the latest stable installer tool again and reinstalled the software. However, this didn’t do any difference. I also tried only downloading just the .zip and extracted the software, and this didn’t do any difference.
Is this some bug in CMake or in Windows or maybe I have somehow installed CMake the wrong way?

Thanks in advance for your help!

Are there any error messages available? Is there any relevant output if you run it from a cmd shell?

FYI: @brad.king

If I run cmake.exe form cmd line, it seems to work properly (I guess), no errors.
If I run the cmake-gui.exe from cmd line, the same thing happens as before and no output or error messages. (so I’m unable to do anything with the gui)
I was checking that, when the CMake GUI appears in the Windows toolbar and I hover on the thumbnail, it shows the last project folder, where I used previously CMake for building. So, might this be some problem that it remembers the last project and somehow tries accessing it? (picture attached on this)

I think the window is appearing off the desktop. If you hover over the icon on the taskbar, do you see the window thumbnail?

Hi,
Yes, that seemed to be the problem! I right-clicked the thumbnail and clicked the window to full screen and got it back to my desktop and now it seems to work fine again. So, the problem was probably that it was off the desktop.

Thanks very much for your help!