The bug that was pushed to discourse. Libtiff not being included in link.txt despite pkg-config providing clear indication of how to include it.

The github issue is included down below.
Please also feel free to view the amazingly long out.txt attached.

link.txt does not include -l option for library cmake indicated was found.

Specifically the tiff library which I do note there is a whole cmake script maintained in this project for.

What is happening is that once cmake has been invoked with a custom prefix in a brand new build directory, the library is being found, and the correct version reported.

It is using the installed version, which I intend it to do.

It is generating a gnu makefile, which I am expecting it to do. It selects the gcc/g++ compilers, which I expect it to do.

So far, so good.

However from the opencv package it generates several link.txt files which are missing the -ltiff flag and so the build bombs with undefined symbols.

This is probably a quick fix for someone who is familiar with the code.

I gathered as much information as possible prior to submitting the issue here and would appreciate a seperate pair of eyes.

Github issue here

of note I’m trying to get this looked at by someone who knows the system very well to determine if this is a cmake bug. which it well might be.

no other lib is being skipped.
multiple other libs are in custom locations and being included fine.
tiff has its own cmake module for finding it.
pkg-config drops the correct information back.
the location of the libs being reported back for libtiff don’t exist.