Issue Compiling Pynest2D Library for Cura

I am currently making my way through the library compilation detailed in the “Running Cura from Source on Windows” article on Ultimaker’s Cura Wiki.

I seem to have hit a snag at Pynest2D. Since as a new user I cannot attach my log files, below you may find Pastebin links to my terminal text and the log files created when I attempt to complete step 5.

Anybody have ideas as to how to best proceed? Thanks!

Terminal Text


I’m almost sure the problem is in the order of the CLI arguments.

I tried it, but looks like I got the same error.
I would like to post the link to the Pastebin, but unfortunately, I get a message from the forum stating the following: “Sorry you cannot post a link to that host.”

In fact, it looks like my previous posts were flagged and hidden for containing hyperlinks.
Is that normal behavior of the auto-mod here?

I guess your post have been hidden because they contained only links.

To the problem itself - for me it looks like the execute_process command in RequirePackage.cmake:131 is somehow wrong. I’d say it’s something the author(s) of that file should take a look at.

@ZachHowell I’ve restored your posts, which did indeed get flagged due to the links. In future, rather than using, I suggest you paste the code directly in the post. For better readability, you can use the following tags to collapse the text with a useful summary line:

<details><summary>A helpful description of the content goes here</summary>

... put your content here


If you want the content to be monospaced, surround the content with the three backticks (```) and make sure there is a blank line between the backticks and the </summary> tag.

1 Like

What led you to that process in particular?

Basically reading your terminal output. There’s enough info in the error messages to identify the place when also looking at the file itself.
But I am not going to debug what exactly went wrong there. It tells you that it tried to invoke CMake with a source directory that has no CMakeLists.txt and I don’t know whose responsibility would be to put/generate that file there.