Install CMake on Mint

I had installed CMake on Mint, I guess. When I execute it notthing happens! Even a negative message appear!

Someone could help me?

Do you mean you are trying to run the CMake GUI (clicking on an icon or selecting CMake from the menu) rather than one of the command line tools (cmake or ccmake)?

Can you clarify how you installed CMake? I’m aware of an issue with symptoms similar to yours for some people who have installed CMake as a snap (recent forum thread can be found here).

Hello, Craig,

Yes, I am cliking on icon. I tried it on Windows 10. It open a screen that has: File, Tools and Options.

It require Visual Studio, that I installed. On message it inform in red :

could not find any instance of Visual Studio.

I tried on Linux Mint, cliking on icon. On Mint noting happens!

Could you help?

Thank you in advance.

Wilmar- Goiânia - Brazil

On social isolation!

If you are comfortable working at a terminal in Linux, could you open up a terminal and run the command


Report back what happens when you do that, including any output that appears in the terminal after you run that command.

Can you please confirm how you installed CMake on Mint. That is a very important detail for this particular problem.

I had installed it last year and I do not remember. It is better to install again. There are many options and I don’t know to choose. Can you help?

My Linux is Mint 19. When I try do uninstall cmake with command

sudo apt purge --auto-remove cmake
system reply: cmake not installed.

So, I proceed with command to install:

administrador-desktop:~$ sudo snap install cmake --classic.

The system reply:

snap “cmake” is already installed, see ‘snap help refresh’

Oh, yes…I got the begining:

administrador@administrador-desktop:~$ cmake

cmake [options]
cmake [options]
cmake [options] -S -B

Specify a source directory to (re-)generate a build system for it in the
current working directory. Specify an existing build directory to
re-generate its build system.

Run ‘cmake --help’ for more information.

I want to open the GUI

On the administrador directory has directory snap. On it there is the cmake directory. On the cmake directory there are the directories:

common current

but they are empty!

I guess I need to re-install it. The directory Example where I can picup CMakeLists.txt and is not there.

I doubt reinstalling will make much difference. Your comments indicate that you do have CMake installed as a snap. That at least helps narrow things down.

To run the CMake GUI from the command line, you use the following command:


Please try that and report what you see here. I suspect you are one of the people seeing the problem that a few others have reported, so I’m quite interested in what the above shows for you.

After you’ve done that, I suggest you remove the CMake snap and install CMake via a different method. First, to remove CMake do the following:

sudo snap remove cmake

Then you can install CMake again from one of the following methods:

  • Download the official CMake package as a tarball and unpack it somewhere. You will need to update your PATH environment variable to include the bin directory of wherever you unpack it to. This should work on just about any Linux distribution. You can find the packages here:
  • I don’t know if the Kitware apt repository would be suitable for your distribution or not. I guess you could try it, but perhaps @kyle.edwards can offer a more informed view on this. You can find details about it here:

BTW @kyle.edwards @robert.maynard it might be good to add a link or some comments about the APT repo on the page to make it more discoverable. Update: I see now that it is there further down the page in the Alternative Binary Releases section, but since it follows after the Previous Release section, I suspect many like myself will rarely scroll down that far to see it.

Dear Craig,

The command cmake-gui was accepted but fail:

ministrador@administrador-desktop:~$ cmake-gui
qt5ct: using qt5ct plugin
qt5ct: D-Bus global menu: no
Falha de segmentação (imagem do núcleo gravada)

So I proceeded to uninstall it:

sudo snap remove cmake

It was removed.

The next step is to re-install…but internet of 1 Mbps and wife on Netflix made me postpone it to tomorow morning!

Thank you Craig.

Dear Craig,

I download the file and put it on a bin directory. After that :

administrador@administrador-desktop:~/bin$ tar -xzvf cmake-3.17.1.tar.gz

Now I am trying to install…

I will inform you if I manage to do.



The releases on are built against Ubuntu 16.04, and are suitable for 18.04 as well. Since Linux Mint is Ubuntu-based, they should work on Mint as well. (I myself have it installed on my Mint computer at home, using the Xenial distro, since my version of Mint is based on Xenial. Newer versions may be based on Bionic, but should still work.)

I follow orientation on On it I choose “For Ubuntu Bionic Beaver (18.04)”, but I am not sure if it was the correct option.

The last command sudo apt-get install cmake was well done.

I think that cmake is installed. How can I start using? I tried the command:

~/bin/cmake-3.17.1$ cmake and ~/bin/cmake-3.17.1$ cmake-gui,

but those commands aren’t found.

Thank you for your advice.


If CMake has been installed, you should see it at /usr/bin/cmake. You can also run:

$ dpkg -L cmake

to see the list of files installed by the package.

If you want cmake-gui, you will need to install it separately from the cmake-qt-gui package.

I guess the command confirm it was installed:

administrador@administrador-desktop:~/bin/cmake-3.17.1$ dpkg -L cmake

I need to start using, but how?

Thank you for an advice.


Is /usr/bin in your $PATH?


I think so:

administrador@administrador-desktop:/usr/bin$ echo $PATH


but, even inside the directory ~usr/bin the command cmake didn’t function:

administrador@administrador-desktop:/usr/bin$ cmake

cmake [options]
cmake [options]
cmake [options] -S -B

Specify a source directory to (re-)generate a build system for it in the
current working directory. Specify an existing build directory to
re-generate its build system.

Run ‘cmake --help’ for more information.

but it stays there:

administrador@administrador-desktop:/usr/bin$ ls -lag cmake

-rwxr-xr-x 1 root 8309336 abr 9 17:09 cmake

Thank you, once more, by an advice.


It looks like it’s working. The fact that it’s showing usage information means that CMake is installed, and you are running it successfully. The problem is that you haven’t given it a source or binary directory. cmake is a command-line tool meant to take an argument. If you want a more graphical solution, you will need to install cmake-qt-gui and then run cmake-gui.