I tried installing cmake with the command “./bootstrap”.
I get this error message:

CMake Error at Utilities/cmcurl/CMakeLists.txt:454 (message):
Could not find OpenSSL. Install an OpenSSL development package or
configure CMake with -DCMAKE_USE_OPENSSL=OFF to build without OpenSSL.

I guess I don’t need OpenSLL, so fine, I could run configure with this flag, but how do I do this? Do I have put this somewhere in a file, or do something else?
I tried running “./bootstrap -DCMAKE_USE_OPENSSL=OFF” but that didn’t work.



bootstrap --help gives the answer:
Usage: ./bootstrap [<options>...] [-- <cmake-options>...]

-DCMAKE... is a cmake option so you have to specify it this way:
bootstrap <options> -- -DCMAKE_USE_OPENSSL=OFF

1 Like

Thank you. Now it works.
Thank you very much,

1 Like

I have not get the solution, what should be filled into the ?