Getting unwanted errors while running the project.

I am getting errors something like

$ cmake ../openchemistry
CMake Error at CMakeLists.txt:2 (project):

   'nmake' '-?'

  failed with:

   no such file or directory

CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
-- Configuring incomplete, errors occurred!

when i am using cmake ../openchemistry command. I don’t know what is the cause. Please help me to resolve this issue. It’s pretty urgent. I have not used cmake before, so i am unaware of the cause.

Would need to know the URL of the project. Looks like you’re on Windows; you would need to be running from the Visual Studio Command Prompt.

No @scivision , I am in the command promt of vs code only. Getting always the same errors. Can I send you the repo link?

this is the repo link, also there’s a way to build the project here Build -
when i use these commands

 mkdir openchemistry-build
 cd openchemistry-build
 cmake ../openchemistry
 cmake --build . --config Release

in the third one, cmake …/openchemistry i get errors.

Also tagging @Garrett , since i was looking similar post by him with a solution but didn’t get it. Please help me with this. it’s pretty urgent for me rn @scivision

Ooh wait…do you mean it should run in visual studio not in visual studio code? @scivision

update: I kinda tried to debug it and now its showing me something like

C:\Users\permi\Desktop\openchemistry-build>cmake ..\openchemistry
CMake Error at CMakeLists.txt:81 (find_package):
  By not providing "FindQt5.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt5", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt5" with any of
  the following names:


  Add the installation prefix of "Qt5" to CMAKE_PREFIX_PATH or set "Qt5_DIR"
  to a directory containing one of the above files.  If "Qt5" provides a
  separate development package or SDK, be sure it has been installed.

-- Configuring incomplete, errors occurred!

Would be very nice of you all if you suggest me where’s the problem?

It looks like the original problem is resolved. You’ll need to get Qt5 and point CMake at it (probably with either -DQt5_DIR=/path/to/qt/root/lib/cmake/Qt5 or -DCMAKE_PREFIX_PATH=/path/to/qt/root).

Oh…yes that worked for me thanks so much. The problem left is, when it runs the whole command without encountering a single error, there’s no .exe file created from where I could run my project.

when I try to run make command it shows me make: *** No targets specified and no makefile found. Stop.

Do you have any tips for this? @ben.boeckel

You’re probably not using a Makefiles generator. cmake --build . is the reliable way to build any CMake build tree (possibly with --config ConfigName for multi-config generators).