FetchContent ignores CMAKE_MODULE_PATH set in subproject

I have several self-contained CMake-based library projects. They all build fine when built on their own, but problems arise, when I try to use them in a main project in connection with FetchContent.

One of the problems is, that I have an additional file included file with macros and variables, that is not found, when the libs are built as subproject.

The path is cmake/my_macros.cmake and I tried
before the

How do I have to modify the subprojects CMakeLists.txt to correctly work stand-alone and as subproject?

A hint to an example project or a howto for this kind of nested projects would also be helpful. Most what I have found is too simple and blows up in my face when extended.

Edit: I know, I can have a
list(APPEND CMAKE_MODULE_PATH ${subproject_SOURCE_DIR}/cmake)
in the main project after the call to FetchContent_Declare. But all the libraries use the same name for the included file but might have different contents in this file, so fetching multiple libraries create a naming collision.

Okay, my own fault or rather a dirty build directory. Somehow changing ${CMAKE_SOURCE_DIR} to ${CMAKE_CURRENT_SOURCE_DIR} wasn’t effective when reconfiguring. After cleaning the the build dir and restarting the configuration process worked fine, so
is the way to go.