Facing issues while trying to upgrade Cmake 3.16.3 to 3.24.0 in WSL-Ubuntu 20.04


I am trying to upgrade Cmake in my WSL – Ubuntu 20.4 environment from 3.16.3 to 3.24.0 following the instructions in Kitware APT repository webpage.
However I am getting the below errors while running step 2:-
"ERROR: cannot verify apt.kitware.com’s certificate, issued by `CN=Zscaler Intermediate Root CA (zscloud.net) (t)\, OU=Zscaler Inc., O=Zscaler Inc., ST=California, C=US’
Unable to locally verify the issuer’s authority "

Also manual tried to copy the public key in a local file x.asc and tried to executed below commands :
cat x.asc | gpg --dearmor - | sudo tee /usr/share/keyrings/kitware-archive-keyring.gpg cat /usr/share/keyrings/kitware-archive-keyring.gpg | sudo apt-key add -

However when I run sudo apt update, it gives me below error:

Our work laptops are installed with Zscaler client service by our organization. (Google search ZScaler if not familiar.) I am not sure if Zscaler client is the culprit here preventing these steps to progress.

Could anyone please share any thoughts regarding these issues and please advise me how to sort out this issue of upgrading CMake 3.16.3 to 3.24.0.?

Thank you in advance for your understanding and support.
Looking forward to hearing from you soon.


Honey Sukesan

That certificate doesn’t match what I see for apt.kitware.com. It looks like ZScaler is intercepting the connection and the certificate isn’t matching. Is there an external proxy you should use instead? Perhaps the certificate store needs synchronized between Windows and WSL?

1 Like

Thanks for the guidance, Ben. I will try with proxy enabled and will respond here.