error: source file is not valid UTF-8


so the situation is: from Win10 64 I run Virtual Machine where the guest is MacOS, From Win10 I share a folder with all projects (sources as well as builds folders). When opening projects and run Cmake which creates build folder on guest macOS, all is fine, when the Cmake creates build folder on host shared folder location, it gives an error:
error: source file is not valid UTF-8
to me, I think this is the false report, the cmake from macOS creates the build files itself, so its not reading any files from another drive (even virtualy shared).

Attached you can see all files form build directory created from guest to host virtualy shared folder

I tries with CMake 3.27.7, but same applies for 3.24.4

PS: what is REALY interested, that if I configure the project to real iOS device, then CMake wiill handle fine without this error. But when I configure the project for iOS Simulator, this error appears I have checked with QT Support, and we discovered this is CMake topic rather then QT topic

Is there anything which can be done from CMake side? to somehow force creating UTF8 encoding?

What is providing that error message? I don’t see the text of it in CMake itself at least.

i run QT6, i tried to find out the issue with QT support and they actually told me to open the bug report here direcly on CMake, see:
[QTBUG-122438] iOS Simulator wont handle CXX on fresh project but example works - Qt Bug Tracker

lateron i found out its common virtual machine problem, see:
mount - Error source file is not valid UTF-8 when sharing project code from Ubuntu host to macOS guest - Stack Overflow