ctest_submit errors when sending https to experimental "self-signed" CDash server

When attempting to send results to an experimental CDash server using ctest_submit and an https URL, I am getting the following error message (which makes sense):

Error when uploading file:...
Error message was: schannel: SEC_E_UNTRUSTED_ROOT (0x80090325) - The certificate chain was issued by an authority that is not trusted.
Problems when submitting via HTTP

ctest version 3.26.3
Windows (presumably same on other OSes)

The question is:
Is there a way to force this submit to work without having a fully secure https server?
Some var I can set to ignore this error?
Some chain of trust I can add my certificate to?

I can’t get a real server name and a corresponding certificate until my experiment proves this is going to work right…


There are a number of places CMake allows for ignoring certificate validation; I’m not sure if this is one of them though.

You can try setting CMAKE_TLS_VERIFY to 0 in the relevant CTest script (no idea if/how you can affect the ctest -D *Submit mechanisms).

Thanks for the suggestion. Tried it, didn’t work, but then, I went to the source code.

Looked in the submit handler source file and found this chunk:

Then found this in the doc, pointing to CurlOptions and CTEST_CURL_OPTIONS

Using this in my ctest -S script worked:


Thanks for the discussion. Now the next googler of ctest + “The certificate chain was issued by an authority that is not trusted” has a shot at finding a workaround quickly. :slight_smile: