compile CMake (32 bit) with Visual Studio 2019

dear experts,
I installed both Visual Studio 2017 and Visual Studio 2019 on my Microsoft Windows 10 workstation.
I tried to compile cmake as a 32 bit application and did not manage to get it compile with Visual Studio 2019 while it works with Visual Studio 2017.
Here are the steps after I downloaded cmake sources.

call "C:\Program Files (x86)\Microsoft Visual Studio\2019\\Community\VC\Auxiliary\Build\vcvarsall.bat"  x86
mkdir build
cd build
cmake -DCMAKE_BUILD_TYPE:STRING=Release -A Win32 -Thost=x64 -DCMAKE_GENERATOR="Visual Studio 16 2019" ..
msbuild  /p:Configuration=Release ALL_BUILD.vcxproj  /p:PlatformTarget=Win32
msbuild   /p:Configuration=Release INSTALL.vcxproj  /p:PlatformTarget=Win32

I get errors at compilation stage:
C:\Program Files (x86)\Windows Kits\10\Include\10.0.17763.0\um\oaidl.h(487,17): error C2059: erreur de syntaxe├┐: '/' (compilation du fichier source D:\S\XXXXXX\SOURCES\cmake\Source\kwsys\Terminal.c) [D:\S\XXXXXXXX\BUILD\cmake\Source\kwsys\cmsys.vcxproj]

On the other hand, if I use Visual Studio 15 2017 as CMAKE_GENERATOR it works, and I checked that the generated binary is 32 bits as returned by 7z utility:
7z l cmake.exe|findstr CPU
CPU = x86

Am I missing some import step in my build procedure, given it works with Visual 2017 ?
Thanks for your valuable help.

What is the actual syntax error on this line of the file?

Have you tried the latest kit? I have 10.0.18362.0.

thanks for the hint. Moving to 10.0.19041.0 resolved the issue!
Just in case one hits the same issue, in order to target a given SDK version, I added to the cmake command line:
-DCMAKE_SYSTEM_VERSION=10.0.19041.0