Cmake compiler tool

I tried to confirm the cmake confirmation on iOS 11.1, but I get incomplete error because ((CMake Error at CMakeLists.txt:3 (project): The CMAKE_CXX_COMPILER:


is not a full path to an existing compiler tool.

Tell CMake where to find the compiler by setting either the environment variable “CXX” or the CMake cache entry CMAKE_CXX_COMPILER to the full path to the compiler, or to the compiler name if it is in the PATH.))

How can I solve it?

Best regards…

Do you have a space before /Library in your code or is that just an artifact on DIscourse?

it is just an artifact. I found a file with the name of cmake complier and CMake cach. When tried to put the path into the CMake in terminals. It ends up by deleting the 2 files??

Do I have to make a new files and locate the path into cmake terminal? and how can I do it??

Best regards…

Have you installed Xcode and started it once?

yes, I install it and lunch it. what can I do next?

To be honest am a physician and I don’t have that much of experience in the terminals and cmake programs, I want to install the dicom2mesh and orthomesh to help my patient for planning their operations, it is not a business work.I am trying to help my patient with whatever I have, If anyone can help me through this I will be glad and thankful for him.

When I Opened a new terminal and try to confirm the cmake to open the cmake window, I get this message

CMake Error: The source directory “/Users” does not appear to contain
Specify --help for usage, or press the help button on the CMake GUI.

It seems that you’ve given /Users as your source directory for CMake to try and build? What command did you run?

The compiler should now be set up properly. Xcode does some post-install steps that it needs to work from the command line only after it is first run.

Now I am facing these difficulties, I don’t have much of experience in terminal. I don’t know what to do with these

I don’t have a cmake list or cash or complier files, What can I do with it?

You need to point CMake at the source directory that you want to build. This section is a decent place to start.

When I try to solve the source directory and configuration. I got this

This is a problem with the project in question (DicomToMesh?). This error should be reported to the developers of that project.