Can we compile Azure IoT C SDK for ArmV4I platform?

I’m currently trying to compile the Azure IoT C SDK in ArmV4I. My system can’t be modified or upgraded and the different solutions on internet to compile only Arm (ArmV7) doesn’t match with my machine.

Machine specs :

CPU : i.MX6 solo (ArmV4I)

OS : Windows CE 7.00 build 2882

I’ll try to respond as fast i can, thanks for all the users that will try to help me.

I’ve already tried to compile the Az IoT SDK on CMAKE with the Windows mobile 5 SDK coupled with VS 2008 but it doens’t run.

I also tried to build and execute an ARM project on recent Visual Studio with the right SDK but i noticed that was built in ArmV7, which doesn’t work on my device.

I’ve tried many solutions that we can find on this platform and others to solve my problem but nothing worked.

I think the first thing to do would be to locate a toolchain that could be used at all. It sounds like you have an armv7 toolchain at least. I don’t know if it can be configured using the -A flag on the first configure or not though.

@brad.king in case you know what to look for here.

Hi @ben.boeckel ,
I’m not totally shur to understand what you told before. My current platform doesn’t support toolchains above ARMv4I, so it can’t works with a higher Toolchain as an ARMv7.
Thanks for your responding.
Best regards

Right, I should have been clearer. I think the first step is to get CMake to even use an armv4l-targeting toolchain at all. For Visual Studio generators, this is controlled via the -A flag (CMake now has a dropdown for this in the GUI, but I don’t remember when it was introduced; probably after VS2008 support was deprecated though). I don’t know how the architecture you need is spelled in VS-land though; it’s tied to VS and its toolchain namings rather than CMake choosing a name. You may be able to convince the VS2013 to use a toolchain from 2008 though (-T v90 or something) which would allow for more modern CMake where the GUI may be able to help guide more.