Warning: Did not find file Compiler/-ASM How to solve this warning??Even though Warning build is happen is it correct build or not??

Warning: Did not find file Compiler/-ASM

It looks like the platform was not detected; the skipped on the C compiler check is probably related. Are you using a toolchain file? If so, you probably need to give the platform name.

The Green Hills MULTI generator hasn’t been tested when enabling ASM as a language. I’ve only used C CXX. If you don’t enable ASM as a language you still could add the assembly files to the target. I think there is a decent chance that the target would build correctly.

The skipped is a normal CMake message since 3.18 when the ABI works, see https://gitlab.kitware.com/cmake/cmake/-/merge_requests/4789#note_797935

I’d go by fdk17’s response as it seems the GHS Multi generator just doesn’t support ASM yet.

I’ve tested this out; You can add .s files as sources and it will be built into the executable.