Linux 32bit cmake available?

I am trying to install a 32bit version of cmake on my Xubuntu 18.04 32bit system using a script like this:
mkdir ~/temp
cd ~/temp
sudo mkdir /opt/cmake
sudo sh cmake-$version.$ --prefix=/opt/cmake

The binaries that get installed are 64bit binaries. How can I get 32bit binaries?


As far as I know, does not offer 32-bit Linux binaries. You have two options:

  1. Build it yourself using the bootstrap script. All you need is a C and C++ compiler.
  2. If you’re using Ubuntu, you can use the Ubuntu builds at
1 Like

I did try the bootstrap script method, but it complained about some things missing from my gcc compiler … I don’t typically compile code on linux, so I gave up on that since I didn’t really know what to do about it. Your second suggestion works like a charm! I now have cmake 32bit running on my Xubuntu 18.04 32bit system. I am going to update my process to get cmake installed in this manner going forward. Thanks so much.

Glad to hear the apt repository worked out.

As a matter of interest, what kind of error was the bootstrap script throwing? That is tested pretty thoroughly.

Cannot find a C++ compiler that supports both C++11 and the specified C++ flags. I initially performed apt install gcc. I get that error, so I took a guess and tried apt install gcc++, but that results in a many conflicts, so it fails to install. Like I said, I am new to compiling code on linux, so be kind :wink: