cmake 3.28.0-rc3 fails to build qt6 via vcpkg


I just tried to build qt6 via vcpkg and it failed. I first thought it is a vcpkg problem but switching to 3.27 solved it (and failed later due to a different error)

The error message was:

CMake Error in C:/Development/vcpkg-clion/vcpkg/buildtrees/qtbase/x64-windows-rel/CMakeFiles/CMakeScratch/TryCompile-qarcjy/CMakeLists.txt:
The target named “cmTC_fd527” has C++ sources that may use modules, but
modules are not supported by this generator. See the cmake-cxxmodules(7)
manual and the CMAKE_CXX_SCAN_FOR_MODULES variable.

System specs:

  • win11, 64 bit
  • MSVC 19.37.32822.0
  • cmake 3.28.0-rc3


Can you please test release branch directly? This MR should have fixed this:

sorry, I just stumbled on this so I have no experience. What’s the easiest way to do this? Is there a pre-built version somewhere or do I have to build cmake myself?

There are nightly master builds here:;O=D It was merged on 1 Nov, so if it is broken on 31 Oct and works on 1 Nov or 2 Nov, that would be a good indicator that it is fixed. But rc4 should be out this week.

I used the nightly from the 5th and can’t reproduce it.

Thanks. rc4 is out now as well.